Unable to approve new identities, revoke and reverify identities

Incident Report for Scurid Cloud

Resolved

Issue has been resolved.
Posted Feb 11, 2026 - 13:17 UTC

Monitoring

Monitoring the services closely, after the fix.
Posted Feb 10, 2026 - 18:43 UTC

Identified

The issue has been identified and fix has been implemented.
Services seem nominal, we are closely monitoring the situation.
Posted Feb 10, 2026 - 18:42 UTC

Update

Investigation in progress
Posted Feb 09, 2026 - 21:54 UTC

Investigating

Users are unable to onboard new device identities, revoke existing identities or reverify statuses of currently active identities.
Posted Feb 09, 2026 - 21:13 UTC
This incident affected: SSI Service.